[image: ]
Import the Model
1. Open CADfix
2. Navigate to folder
3. Change File type to “CADFIX GDX”
4. Highlight “F22_Model_.gdx”
5. Check “Import Only” box
6. Click “Go”
7. Type "PLOC BGND LG" and hit enter.
8. Rotate and Inspect the imported Model
Set the Display
1. Open CADfix
2. Click the "View" button on the upper toolbar, go to the "Display Quality" drop down menu and select "0.1".
[image: ]

Create the Major Sets from the Hierarchy
1. Click the hierarchy icon [image: ] on the left, then the assembly button[image: ]
2. Type “SETA SEAMS Z4” in the command window.
3. Type “SETA WINGS Z6” in the command window.
4. Type “SETA HSTAB Z8” in the command window.
5. Type “SETA CANOPY Z10” in the command window.
6. Type “SETA FUSEL Z12” in the command window.
Create the Charging Source Channel
1. Type "PLOT G ALL"
2. Select the "Probe the model geometry" tool [image: ] , use the "Probe: Points" [image: ] method and select a point on the nose of the aircraft.
[image: ]

3. Record the name and x, y, z coordinates of the point, they will be needed.
4. Type "PLUS PA QL78"  where QL78 is the name of the chosen point
5. Open the tools menu [image: ] on the left
6. Click build->create/edit points
7. Enter in the following coordinates and click Apply:
x: 	-0.11196 (x coordinate of previous point)
y:	-10
z: 	-0.17924 (z coordinate of previous point)
[image: ]
8. Note the name of the point created in the lower left hand corner of the window.
[image: ]
9. Type "PLUS PA QA00" where QA00 is the name of the newly created point.
10. Type "PLUS SI ALL DG" in the command window. 
11. Click build->create/edit lines in the tools menu.
12. Select the "two point" method. Click a point on the nose of the F22 and then select the point created earlier.
[image: ]
13. Click “Apply”
14. Note the Line Name noted below, such as [image: ]
15. Type “PLUS LA WFB2” in the command window, where WFB2 is the name of the newly created line.
16. Type “SETA ATTACH WFB2” in the command window, where WFB2 is the name of the newly created line.


Specify Units, Define Lattice, and Mesh Geometry
1. Type “RNAM UNIT” in the command window.
2. Open Tools->Toolbox->EMA3D_#2_SpecifyUnits, as shown below:
[image: ]

3. Click “Units” [image: ] from the right side of the screen. 
4. Select the “meters (m)” radio button.
5. Click “OK”

6. Open Tools->Toolbox->EMA3D_#3_DefineLattice, as shown below:
[image: ]
7. Select “ConLatt” [image: ] from the right side of the screen.
8. Enter the following lattice parameters:
X = -10 to 10
∆X = 0.05
Y = -10 to 20
∆Y = 0.05
Z = -4 to 6
∆Z = 0.05

[image: ]
9. Click “OK”
10. Type “PLUS LATE” 
11. Make sure the lattice surrounds the entire craft with a few meters of padding on each side.
12. Open Tools->Toolbox->EMA3D_#5_MeshGeometry.
[image: ]
13. Select “Mesh” button from the right menu.
14. Type “PLOT TWI ALL” in the command window and inspect the mesh to make sure everything is present






Define Time Step
1. Open Tools->Toolbox->EMA3D_#6_DefineTimeStep.
2. Select “TimeStep” [image: ] from the right menu.
3. Enter “8.66e-11” in the “Time Step (s)” field.
4. Enter “92379” in the “Number of Time Steps” field, as shown below.

[image: ]
5. Click “OK”
Define the Materials
1. Open Tools->Toolbox->EMA3D_#8_DefineProperties.
2. Select “PROPERTY” [image: ] from the right menu.
3. Click “New” in the “EMA3D Property Editor” window.
4. In the “Name” field of the “New Property” window, type “SKIN”
5. In the “Type” spin box, change the definition to “Isotropic Surface” as shown below
[image: ]
6. Click “OK”
7. In the “Isotropic Surface” popup window, enter “2.5E4” in the “Electric Conductivity” field.
8. Leave the other fields as the default, as shown below:
[image: ]
9. Click “OK”
10. Click “New” in the “EMA3D Property Editor” window.
11. In the “Name” field of the “New Property” window, type “SEAM”.
12. In the “Type” spin box, change the definition to “Isotropic Surface”.
13. Click “OK”
14. In the “Isotropic Surface” popup window, enter “5.26” in the “Electric Conductivity” field.
15. Leave the other fields as the default.
[image: ]
16. Click “OK”
17. Click “New” in the “EMA3D Property Editor” window.
18. In the “Name” field of the “New Property” window, type “MGLS”.
19. In the “Type” spin box, change the definition to “Isotropic Surface”.
20. Click “OK”
In the “Isotropic Surface” popup, enter "0.08” in the “Electric Conductivity” field [image: ]
21. Click "OK".
















Assign the Materials
1. Highlight “SKIN” in the “Property Editor” popup window.
[image: ]
2. Click “Assign” in the “Property Editor” popup window.
3. Type “FUSEL” in the “Assign Property” popup window.
[image: ]
4. Click “Apply”
5. Type “WINGS” in the “Assign Property” popup window.

6. Click “Apply”
7. Type “HSTAB” in the “Assign Property” popup window.
8. Click “Apply”
9. Select “SEAM” in the “Name of Property” spin box of the “Assign Property” popup window.
10. Type “SEAMS” in the “Assign Property” popup window.
11. Click “Apply”
12. Select “MGLS” in the “Name of Property” spin box of the “Assign Property” popup window.
13. Type “CANOPY” in the “Assign Property” popup window.
14. Click “OK”
15. Click “Close” in the “Property Editor” window.
Define Sources
1. Open Tools->Toolbox->EMA3D_#10_DefineSources.
2. Select “Source_Tool” [image: ] from the right menu.
3. Change the "Select Analytic Function and Time Value" to Gaussian.
4. In the “EMA Source Tool” field, change the “Time Step” to “8.66e-11”.
5. In the “Final Time” field, change the value to “8.0e-6”
6. In the "A parameter" field, change the value to "1.0e4".
7. In the "t0" field, change the value to "4.0e-6".
8. In the "Alpha" field, change the value to "5.0e11".
9. Click “Plot Source”
10. The results should be the same as below:
[image: ]
11. Click “Finished”.
12. Click “OK”.
13. Type “PRNT L ATTACH” in the command window.
14. Note the name of the line echoed, such as “WFB2”
15. Type “SETA ATTACH N WFB2” in the command window, where WFB2 is the name of the line echoed in the previous step.
16. Select “EleCurDen” [image: ] from the right menu.
17. Enter “dexp.dat” in the “Source File Name” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
18. Enter “ATTACH” in the “Set of Nodes to be Loaded” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
19. Enter “1.0” in the “Y-Component Multiplier” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
20. Leave the other parameters at the default, as shown below:
[image: ]

21. Click “OK”
Select Boundary Condition
1. Open Tools->Toolbox->EMA3D_#11_SelectBdyConds.
2. Select “BOUND” [image: ] from the right menu.
1. 
2. 
3. Click the “MURL (HFLD)” radio button in the “All” column of the “Boundary Conditions” popup window
[image: ]
4. Click “APPLY”.

Define Surface Normal E-Field Probes
1. Open Tools->Toolbox->EMA3D_#12_DefineProbes.
1. Type the following into the command line:
RNAM TRAP
RNAM TEMP
SETA TRAP S ALL
COMP TRAP GN
SETR TRAP S ALL
SETA TEMP L ALL
COMP TEMP GN
SETR TRAP TEMP
2. Type “PLOT TWI TRAP” into the command line and observe the aircraft nodes.
3. Select “Traditional” [image: ] from the right menu.
4. Type “TRAP” in the “Set Name” field.
5. Click the “NE” radio button in the “Output type” field
6. Type “8e-6” in the “Stop time” field
7. Type “2E-7” in the Step time” field, as shown in the figure below:
[image: ]
8. Click “OK”

Define Bulk Current Probes
1. Type "PLOT SI WINGS DG" into the command line and rotate the view so you can see the inside of the left wing where it attaches to the fuselage.
[image: ]
2. Type "SETA BP1" into the command line.
3. Open the Set Manager by clicking the [image: ] icon.
4. From the drop down menu select the set BP1 and highlight the surface select method.
[image: ]
5. Select all of the surfaces (there are 11) that meet the fuselage and close the manager. 
[image: ]
6. Type "PLUS SI HSTAB DG" and rotate the view screen so the inside of the Left horizontal stabilizer can be seen in the same manner as the left wing. 
7. Type "SETA BP2" and open the set manager.
8. Select the inner surface of the LEFT horizontal stabilizer (there is only 1 surface). Close the set manager.
9. From Tool->Toolbox-> Tools->Toolbox->EMA3D_#12_DefineProbes click the BulkCurr [image: ] button.
10. Type "BP1" for the "Bulk Current Probe Set Name".
11. Select a point on the tip of the leading edge of the inside of the wing and enter it as the "First Bounding Point"
[image: ]
12. Repeat the above process for a point at trailing edge of the inside of the wing.
[image: ]
13. Leave "Current Type" as "Electric"
14. Change "Stop Time" to 8e-6.
15. Change "Step Time" to 8.66e-9
16. Change "Normal Direction" to X
17. Click Apply.
18. Change "Bulk Current Probe Set Name" to BP2.
19. Repeat the bounding point selection process the same as before selecting these points:
[image: ]
20. Leave all other entries the same and click "OK".



Prepare the 3D Simulation Input File
1. Open Tools->Toolbox->EMA3D_ReviewTool.
2. Select “Review” [image: ] from the right menu.

3. The following window will appear.

[image: ]
4. Review the simulation details, and click “Create EMA3D Input File”  [image: ] when ready to proceed.
5. Note the file name and click “OK” in the popup window.
Run EMA3D Simulation
1. Open Tools->Toolbox->EMA3D_Run_EMA3D
2. Select “Run_EMA3D” [image: ] from the right menu.
3. Select the “Run New EMA3D Simulation” radio button.
4. Click “Browse”
5. Select the .emin file by the same name created in the FTE step above.
6. Click “Open”
7. Click “Run EMA3D”
8. Wait for the simulation to complete. Observe the progress of the plot by clicking on the probe table items. The window is shown below:
[image: ]

Create Normal E-field Animation
1. Save the CADfix database.
2. Close CADfix
3. Open Windows Start menu and click run. On Windows 7, type directly in the Start Menu search box.
4. Type “cmd.com” to open a command window.
5. Type “cd /d <folder location>”, where <folder location> refers to the working directory from above.
6. Type “famfromema3d” into the command window.
7. Type the name of the .emin file, such as “F22_P-Static”.
8. An example of the command line execution is below:
[image: ]
9. Open the CADfix database file saved above, such as “F22_P-Static.fbm”
10. Click the post-processing tab on the left side of the CADfix window [image: ]
11. Wait on the database to load.
12. Check to ensure the traditional probe of set “TRAP” is visible for each time point, as shown below:
[image: ]
13. Type "CHEC" to make sure that the results database matches the model.
14. Type “RNAM RD01” into the command window.
15. Type “RNAM RD02” into the command window.
16. Open View->Display Settings and open the “Mesh” tab
17. Change the “Element edge colour” to “off”
18. Change the “Mesh shrink factor” to “off”
[image: ]
19. Click “OK”
20. Navigate back to the Post Processing tab [image: ]
21. Click on one of the Traditional probe values to reveal its data parts.
[image: ]
22. Click on the non-time value so that it is highlighted.
23. Click on the "Animate" [image: ] button to bring up the next animation window.

24. The next window should contain a list of all TRAP data points. Click the " Contour range..." [image: ] button. 
25. Click "Ok" on the warning pop-up.
26. Enter "3E6" as the maximum value and click "Apply" and then "Close".
[image: ]

27.  Click the "Select All" [image: ] button. Then click the "Capture" [image: ] button.
28. A new window should appear showing the progress of the animation being created. During this time the  Cadfix window should be slowly advancing, frame by frame,  the animation that is being created.
29. When the animation ends a video editor window will appear, from here the video can be edited, formatted and saved as desired.
[image: ][image: ]


Post-process the E-Field Results
1. Using the Traditional Probe animation as guide we can check E-field probe values in areas of interest.
2. Using the "Animation manager" set the playback speed to 45. 
[image: ]
3. Advance the film until the first red areas appear, they should be on the tips of the vertical and horizontal stabilizers.
[image: ]
4. Make a note of the time this occurs at. (should be about 3 microseconds)


Analyzing the Left Horizontal Stabilizer 
1. Copy the .fbm file associated with your model and copy it to a new directory. Also copy the YourFIlenamebpr2.dat (Bulk Current Probe Results for the left horizontal stabilizer) into the new directory. Open your .fbm in CADfix.
Selecting Left Horizontal Stabilizer 
1. Type "PLOT SI HSTAB DG" into the command line and hit enter.
2. Type "QADD LHSTAB" and hit enter.
3. Press "a" on the keyboard, a box will appear.
4. Draw a circle around the left horizontal stabilizer, each time the "n" key is pressed a node will be created at the cursor location, use these to draw the circle.
[image: ]
5. when the circle is complete press the "w" key and then "s", "l", and "p" in that order and then hit enter.
6. Double check only the left horizontal stabilizer was selected by typing "PLOT SI LHSTAB DG" and then "PLUS G LHSTAB"
Creating the Charging Source Channel
1. Using the same technique as before we are going to create a charging channel at the leading edge tip of the left horizontal stabilizer.
2. Query a point on the tip to find its coordinates.
[image: ]
3. Open the Build Toolbox and select "Create/Edit Points"
4. Create a point that has the same X and Z coordinates as the queried point but with a Y coordinate of 9.
5. Open the "Create/Edit Lines" portion of the build toolbox and using the two point method, create a line between the two aforementioned points.
6. Note the name of the newly created line and add it to a new set with "SETA LHATTACH UF0A" where UF0A is the name of the newly created line.
7. Type "PLUS L LHATTACH" and hit enter.
Add Points to model
1. Points must be added to the model so that later probe points can be defined. Start by typing "SETO PPOINTS".
2. In the "Build Toolbox" select "Create/Edit Points" and make sure the "pick position on line" method is chosen.
[image: ]
3. Add points to the Following Areas:
[image: ]
4. When finished change the select method to "Pick Position on Surface". You will be prompted to define which surface, choose the bottom surface of the horizontal stabilizer. Then place points in the following places (points created in earlier steps shown in orange): 
[image: ]
5. Type "SETC ALL" in the command line and hit enter.
6. Type "PLUS P PPOINTS" in the command line and hit enter.
Create Probe Points and Sets
1. Using the points created in the previous step we will now create the individual probe groups we need.
2. Type "SETA CHP1" into the command line, hit enter, open the set manager, and select "CHP1".
3. Making sure the point select method is highlighted select the 6 points on the outer edge of the stabilizer.
[image: ]
4. Close the set manager. Type "SETO LHEXBODY" in the command line and hit enter.
5. Type "COPY CHP1 ! TRA 0.015 0 0" hit enter.
6. Type "SETC ALL" hit enter.
7. Type "SETA CHP2" hit enter and open the set manager.
8. Using the same process as before select the points on the trailing edge of the stabilizer.
[image: ]
9. Close the set manager. Type "SETO LHEYTRL" in the command line and hit enter.
10. Type "COPY CHP2 ! TRA 0 0.015 0" hit enter.
11. Type "SETC ALL" hit enter.
12. Type "SETA CHP3" hit enter and open the set manager.
13. Using the same process as before select the points on the top surface of the stabilizer.
[image: ]
14. Close the set manager. Type "SETO LHEZSTAB" in the command line and hit enter.
15. Type "COPY CHP3 ! TRA 0 0 0.015" hit enter.
16. Type "SETC ALL" hit enter.
17. Type "SETA CHP4" hit enter and open the set manager.
18. Using the same process as before select the points on the bottom surface of the stabilizer.
[image: ]
19. Close the set manager. Type "SETO LHEZBOT" in the command line and hit enter.
20. Type "COPY CHP2 ! TRA 0 0 -0.015" hit enter.
21. Type "SETC ALL" hit enter.
Units
1. Type "RNAM UNIT" and hit enter.
2. Double check that units are still in meters by reselecting meters via Tools->Toolbox->EMA3D_#2_SpecifyUnits.










Define Lattice 
1. Prepare a new lattice with the following sizes (Tools->Toolbox->EMA3D_#3_DefineLattice):
[image: ]

Mesh Model 
1. Type "QADD MESHING" and using the same process from earlier reselect the left horizontal stabilizer and all new geometry created since the original "QADD LHSTAB" command.
[image: ]
2. Open Tools->Toolbox->EMA3D_#5_MeshGeometry.
3. Click the [image: ] button.
4. Click the [image: ] button.
5. Type "MESH MESHING" in the command line and hit enter.
Define Timestep 
1. Open Tools->Toolbox->EMA3D_#6_DefineTimestep.
2. Change the timestep to 1.73e-11.
3. Change the number of steps to 462247. 
Define Prop
1. Open Tools->Toolbox->EMA3D_#8_DefineProperties.
2. From the property editor window delete the MGLS and SEAM properties.
3. using "Assign" assign the SKIN property to the set LHSTAB.
4. Close the property editor.
Define Source
1. Open Tools->Toolbox->EMA3D_#10_DefineSource. 
2. Type “PRNT L LHATTACH” in the command window.
3. Note the name of the line echoed, such as "UF0A”
4. Type “SETA LHATTACH N UF0A” in the command window, where UF0A is the name of the line echoed in the previous step.
5. Select “EleCurDen” [image: ] from the right menu.
6. Enter “F-22_nbbpr2.dat”, where F-22_nbbpr2.dat is the name of bulk current probe results for the left horizontal stabilizer from the first simulation, in the “Source File Name” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
7. Enter “LHATTACH” in the “Set of Nodes to be Loaded” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
8. Enter “1.0” in the “Y-Component Multiplier” field of the “Macro ELE_CUR_DEN_SOURCE Parameters” popup window.
9. Click "OK".
Remove Old Probes
1. Open Tools->Toolbox->EMA3D_#12_DefineProbes.
2. Click the [image: ] button.
3. In the window that appears, delete the probes from the first simulation by clicking select under delete, then click the probe name for the probe you wish to remove.
4. Repeat this until there are no probes left and close the probe manager. There will be one traditional and two bulk current probes.
[image: ]
Define E-field Probes
1. Click the [image: ] button.
2. Complete the form as show below and click apply, repeat this for all four forms shown below then close the NEW2 probe window:

[image: ]
[image: ]
[image: ]
[image: ]

Define Traditional Probe
1. Type the following into the command line:
RNAM TRAD
RNAM TEMP
SETA TRAD S MESHING
COMP TRAD GN
SETR TRAD S ALL
SETA TEMP L MESHING
COMP TEMP GN
SETR TRAD TEMP
2. Type “PLOT TWI TRAD” into the command line and observe the aircraft nodes.
3. Select “Traditional” [image: ] from the right menu.
4. Type “TRAD” in the “Set Name” field.
5. Click the “NE” radio button in the “Output type” field
6. Type “8e-6” in the “Stop time” field
7. Type “2E-7” in the Step time” field, as shown in the figure below:
8. Click "OK"
Create Input File
1. Open Tools->Toolbox->EMA3D_ReviewTool.
2. Select “Review” [image: ] from the right menu.
3. Review the simulation details, and click “Create EMA3D Input File”  [image: ] when ready to proceed.
4. Note the file name and click “OK” in the popup window.
Run EMA3D
1. Open Tools->Toolbox->EMA3D_Run_EMA3D
2. Select “Run_EMA3D” [image: ] from the right menu.
3. Select the “Run New EMA3D Simulation” radio button.
4. Click “Browse”
5. Select the .emin file by the same name created in the FTE step above.
6. Click “Open”
7. Click “Run EMA3D”
8. Wait for the simulation to complete. Observe the progress of the plot by clicking on the probe table items. You can stop the simulation when you see E-field magnitudes above 3 MV/m.


Analyze E-field Probe Resutls
1. From CADfix Open Tools->Toolbox->EMA3D_Run_EMA3D
2. Select “Run_EMA3D” [image: ] from the right menu.
3. Choose "Analyze Existing Results" and click "Browse"
4. Select the .emin from before and click "open"
5. Run the Analysis.
6. Highlight the first probe and click "Analyze Probe".
[image: ]
7. Making sure the "Probed Property" is not "EY" find the probe point with the largest "Y-offset" and click "export to text file".
[image: ]
8. Repeat steps 6 and 7 for the probes that are not measuring the "Probed Property" "EY".
9. For the probe with "Probed Property" "EY" export the probe point with the largest X-offset.
10. Now open the four text files in any text editor.



11. Find the time at which each probe reaches 3 MV/m.
[image: ]
12. Take the shortest time found and integrate the F-22_nbbpr2.dat source file up to that time.
13. The value found, which should be about 900 nC, is the total charge on the left horizontal stabilizer when breakdown occurs. From this we have determined a worst case scenario discharge from the left horizontal stabilizer.
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