
CADfix and EMA3D Training 
Part One 

Introduction 
The purpose of this training module is to build familiarity with the basic functions of CADfix and EMA3D. 

By building a very simple plane model, you will learn basic geometry creation and modification 

techniques. Due to the limited nature of this training module, many CADfix techniques won’t be shown. 

In later modules, more advanced techniques will be explored. 

Almost everything in CADfix can be done using either a GUI (graphic user interface) or using a command 

line input. In this training, both methods will be shown for the applicable steps. Often, beginning users 

find the GUI easier than the command line. However, the command line can greatly increase efficiency 

and more naturally lends itself to the creation of user-written macros. 

Once the plane geometry is constructed, you will follow the steps to turn the CADfix model into an 

EMA3D simulation. The process shown in this module is intentionally left basic to prevent tedium. 

Note: This training was made using CADfix 10 SP2.0 

Getting Started 
1. Open CADfix 

2. Click the “Open Model” button at the top left of the screen 

 

3. Navigate to a folder to hold the files created in this training 



4. Type a file name into the “File name” text field and click “Import” (this will open the file entered 

or create it if it doesn’t exist) 

5. An empty model should be opened. The background might be a dark gradient. To change it to 

white, do one of the following: 



a. Navigate to Display Settings (View->Display Settings). Under the “Basic” tab, change the 

screen background colour to white using the dropdown menu. Change the background 

shading to solid. Leave the other fields unchanged. Click “OK.” 

 

b. Alternatively, locate the command line at the bottom of the screen and type: 

PLOC BGND W 

Then hit enter. To see the change, type REP and hit enter. This will repaint the image. 

“PLOC” accesses the display settings, “BGND” accesses the background settings, “W” is 

white  



6. To get a helpful command menu on the screen (you’ll want this), type PLOC MENU ON and hit 

enter. To force the menu to appear, you’ll have to resize the screen. Now CADfix should look like: 

Constructing Geometry 
Now we’re ready to start making a simple airplane. We’ll make wings, fuselage, and empennage. The 

geometry used in CADfix is composed primarily of points, lines, shapes, surfaces, and bodies. Points are 

the lowest level entities that can be connected to build lines. Lines can be connected into surfaces (with 

an embedding shape). Surfaces can be connected to build bodies. However, bodies are computationally 

heavy for EMA3D simulations and will be avoided in most models. 

Fuselage 
The fuselage will be represented by a rectangular box with rounded forward face, which will represent 

the cockpit. Our fuselage will be 35 meters long. There are many possible methods to build a simple box: 

1. Use “Cube” primitive in the “Primitives” toolbox to create a box body, then delete the body but 

keep the surfaces of the cube. 

2. Create lower level geometries to make the box using the GUI. 

3. Create lower level geometries to make the box using the command line. 

We’ll start by using the primitive: 

1. Make sure the primitives toolbox is open. It should be on the right edge of the window. If it isn’t 

there, activate it by navigating: Tools->Toolbox->Primitives. 



2. Click the “Cube” tool. It should be the first tool in the toolbox 

3. The box will be 33 m long, anticipating 2 m of cockpit. Fill in the parameters as follows (units are 

in millimeters by default): 

4. Type PLOT SI ALL and hit enter.  

a. “PLOT” tells CADfix to clear the image, then add something to the image, i.e. to plot it 

b. “SI” is the type code for shaded surfaces 

c. “ALL” tells CADfix what part of the model to plot, in our case “all” or everything 

5. You should now see a pink box. Using the left mouse button, you can rotate the model. As you 

rotate, you may notice one side is darker than the others. This is a result of CADfix’s default 

shading setting. We can change it to look better. Type PLOC SHAD BOTH and hit enter 



a. This tells CADfix to shade faces of surfaces the same regardless of normal direction. In 

other words, the inside of a box or surface will be lighted the same as the outside. 

b. You will need to repaint the picture by typing REP in the command line before you can 

see the changes. 

Original image on left, image after changing shading setting on right 

 

 

6. You’ll want to keep track of the fuselage. Put it in a set named FUSELAGE. 

a. Click on the “Pick bodies” tool. If it isn’t available, click the “Basic selection” cursor. 

b. Pick the box you just made. 

c. With the box still selected, type SETA FUSELAGE SELE. This tells CADfix to add the 

selected items to a set named FUSELAGE. 

d. Right now, FUSELAGE only contains the body. We want all of the points, lines, and 

surfaces, too. Type COMP FUSELAGE. This tells CADfix to complete the set, adding the 

lower level components. 

(for more information on set management, see “CADfix Notes”) 

7. As mentioned earlier, bodies are computationally heavy and we don’t want them. 

a. Print the names of the bodies in FUSELAGE: PRNT B FUSELAGE 

b. There should only be one body listed. Delete it: DEL B name, where “name” is the body 

name. For the default naming convention, it is W1. 



Create a cockpit: 
1. Open a set to hold the cockpit (an open set will put all new geometry inside it): SETO COCKPIT  

2. Make a point at the origin. This can be done by either using the GUI or commands: 

a. Command line: PNT ! 0 0 0. The “!” tells CADfix to automatically name the point. 

b. GUI: Find the “Tools” tab, then enter the “Build” tree, then click on “Create/edit points.” 

c. Create a point at the origin using the tool by clicking “Apply.” 



3. Add the cockpit points to the image: PLUS PA COCKPIT.  “Plus” adds items to the image without 

removing other entities from the image. The “PA” means points annotated with names. 

4. Create a midpoint between corners of the square face by doing one of the following: 

a. Command line: PNT ! pnt1 pnt2 0.5 

i. Creates point halfway between points “pnt1” and “pnt2.” 

ii. When selecting points, you can use the cursor to select them rather than typing 

their names if you use the arrow keys to highlight “-- pnt” in the menu on the 

right. 

iii. “pnt1” and “pnt2” are opposite corners of the square face (Q1 and Q8 for 

example). 

b. GUI: In the “Create/edit points” tools, select the “Point along a path” tool. Select the 

corners of the square face and leave the ratio at 0.5. Click “Apply.” 

5. Create arcs connecting the corners of the square with the point at the origin. This can be done 

with command line or GUI: 

a. Command line: 

i. LINE ! pnt1 pnt2 centerpnt, where “pnt1” and “pnt2” are arc endpoints and 

“centerpnt” is the center of the arc. The center point is the midpoint of the 

square face. 

ii. Points can be selected with the mouse without typing their names. 

b. GUI: 



i. Navigate to the “Create\edit lines” tools under Tools->Build. Select the arc tool. 

ii. Select the start, end, and center points. Click “Apply.” 

6. Add the new geometry to the image: PLUS G COCKPIT 

7. At this point, you can see that the cockpit isn’t very pointy. Let’s move the forward point to 

make the airplane sleeker. 

a. Command line: MOVE pnt TRA -1000 0 0 

i. To select the point, use the up/down arrow keys to highlight “pnt” in the side 

menu. Now you can use the mouse to pick the points instead of typing their 

names. 

b. GUI: 



i.  In the “Tools” tab, find the “Move/Copy” tool under the “Build” tree.  

ii. Select “Move.” 

iii. Select the “Translate” tool (the default). 

iv. From the dropdown menu, choose point entity types. 

v. Select the point at the origin. 

vi. Click “Define…” A new window will pop up. 

vii. Select “Absolute.” 



viii. Enter -1000 in the “dX” field. 

ix. Click “OK.” 

x. Click “Apply.” 

8. We’re about to create surfaces with the new lines. First, let’s delete the square face so the 

cockpit and fuselage share the same interior. 

a. Select the “Pick surfaces” tool.  

b. Pick the square face. Make sure that the surface is the only thing selected. 

c. ZAP SELE (“zap” is similar to the DEL delete command except that it operates on sets) 

  



9. Make cockpit surfaces: 

a. Find the “Create/edit surfaces” tools under the “Tools” tab, “Build” tree. 

b. In the “General Surface” tab (the default), select the lines that will be the edges of the 

new surface. These will be two adjacent arcs and the connecting straight line on the 

fuselage. 

c. Click “Apply.” 

d. On the pop-up window, click “OK.” 

e. Repeat steps a-d for the remaining three surfaces. 

10. Repaint the picture to see all of the new geometry. 

11. Close all open sets to keep it organized: SETC ALL 

Wings 
The wings will be 1 meter tall, centered along the height of the fuselage, and have a total wingspan of 30 

m, and start 18 m aft of the forward tip of the cockpit. One wing will be created, then it will be mirrored 

to the other side. As with the fuselage, there are several ways to start: 

1. Use “Cube” primitive in the “Primitives” toolbox to create a box body, then delete the body but 

keep the surfaces of the cube. 

2. Create lower level geometries to make the box using the GUI. 

3. Create lower level geometries to make the box using the command line. 

Because the “Cube” technique was already shown for the fuselage, the wings will be built by 

constructing the lower level geometries. The sweep technique will be extensively used, where a lower 

level entity is swept through space to create a higher level entity. 

1. Open a set for the left wing: SETO LEFTWING 

2. Clear or wipe the display: WIPE 

3. Create a master set for the airplane and add the cockpit and fuselage. This will help organize 

things for visualization: SETA PLANE COCKPIT FUSELAGE 

4. Plot the lines of the plane: PLOT L PLANE 

5. Open the master set: SETO PLANE (this will automatically put the left wing in the master set). 

6. Create a point at (17000,500,2000): 



a. PNT ! 17000 500 2000 

b. Use these coordinates in the GUI tool (shown in Fuselage Section). 

7. Add the new point to the image: PLUS PA LEFTWING 

8. Sweep the new point aft 5 meters:  

a. SWEP pnt ! TRA 5000 0 0, where “pnt” is the point you just made. 

b. Or, use the GUI tool to sweep: 

i. Under “Create/edit lines,” use the “Swept line” tool.  

ii. Pick the start point. 

iii. Click “Define…” 

iv. In the pop-up, select “Absolute.” 

v. Enter 5000 in the “dX” field. 

vi. Click “OK.”  

9. Repaint the picture: REP 

10. Sweep the new line down 1 meter to make a surface:  

a. Command line: SWEP line ! TRA 0 -1000 0, where “line” is the new line. 

b. Or, use the GUI tool: 

i. Under “Create/edit surfaces,” use the “Swept surface” tool. 

ii. Pick the start line. 



iii. Click “Define…” 

iv. In the pop-up, select “Absolute.” 

v. Enter -1000 in the “dY” field. The other fields should be zero. 

vi. Click “OK.”  

11. To construct the wing, can either sweep the surface you just made to create a body or sweep 

the lines to create surfaces. If you create a body, you’ll have to delete the body. Because this 

process was already shown when making the fuselage, this document will now show how to 

sweep the lines to make surfaces. Another surface will be needed to close the wing. 

a. Sweep with command line: 

b. activate the “Pick lines:”  

i. Pick the lines that bound the surface created in step 10 (if they aren’t visible, 

make sure to repaint the picture) 

ii. Enter: SWEP SELE ! TRA 0 0 13000 

iii. Repaint the picture: REP 

c. Sweep with GUI: 

i. Follow steps in 10b, choosing the lines created in step 10 as starting points. 

Instead of entering -1000 in the dY field, enter 13000 in dZ (leaving the others 

zero). 

ii. You will need to sweep each line individually with the GUI. 

d. Close the wing: 



i. Add wing surfaces to the image, colored green: PLUS SI LEFTWING G 

ii. Use the “General surface” tool to close the gap in the wing. See steps 9a-9d 

from the Cockpit section for more details. 

iii. Repaint the picture 

12. Check what sets are open and close the ones that aren’t “PLANE”: 

a.  Type PRNT SE 

b. Close any sets that aren’t “PLANE:” SETC LEFTWING 

13. Mirror the leftwing to the right side (X-Y transformation): 

a. Navigate to the “Move/Copy” tool in the “Build” tree, under the “Tools” tab. 

b. Click “Copy.” 

c. Switch to the “Mirror” option. 

d. Type “LEFTWING” into the selection field and hit enter. This will select everything in the 

LEFTWING set for copying. 

e. In the dropdown menu for point selection, choose “Pick mid-point of line.” 



f. Select the upper and lower lines at the rear face of the fuselage, as well as the upper 

line where the cockpit joins the fuselage. Midpoints of these lines will make an X-Y 

plane. 

g. Click “Apply.” 



h. A popup will ask for a “New part name,” enter “RIGHTWING.” This will put the new wing 

in a set named RIGHTWING. 

i. Click “OK.” 

14. Plot all of the shaded surfaces in PLANE in blue: PLOT SI PLANE B  

Vertical Stabilizer  
To make the vertical stabilizer, we will copy, rotate, and move one of the wings. 

1. Plot the lines in PLANE: PLOT L PLANE 

2. Add the points (with labels) to the image: PLUS PA ALL 

3. Navigate to the “Move/Copy” tool. 

4. Select “Copy.” 

5. Type “LEFTWING” into the selection box. 

6. Switch to the “Rotate” option. 

7. Select “Two points” to define the axis of rotation. 

8. Choose the point at the tip of the cockpit and a point directly aft of the tip. 



9. Enter “-90.0” as the angle (right hand rule determines the sign). 

10. Click “Apply.” 

11. Enter “TAIL” as the part name in the popup. 

12. Wipe all points from the image to help visibility: WIPE PA 

13. Add the surfaces of the tail to the image, in green: PLUS SI TAIL G 

14. Move the tail aft 11 meters: 

a. MOVE TAIL TRA 11000 0 0 

b. Repaint the image 

15. Shorten the tail: 

a. Navigate to the “Move/Copy” tool. 

b. Select “Move.” 

c. In the selection dropdown, pick surfaces. 

d. Select the upper face of the tail. 

e. Stay on the “Translate” option. 

f. Select “Two points” for the vector definition. 

g. For the first point, select a corner of the upper face. 



h. For the second point, use the dropdown to change to “Position on line” and pick a 

position along the line underneath the first point. The position you pick will be the new 

height of the tail, so pick a height that looks reasonable (around 1/3 the total height 

works well). 

i. Click “Apply.” 

j. Repaint the picture. 

Finishing Touches 
The airplane doesn’t look much like an airplane. Let’s assign a realistic color to it. 

1. Plot the plane using assigned colors: PLOT SI PLANE ASGD 



2. Notice the pink coloring. Pink is the default if no color is assigned. 

3. Select the “Pick surfaces” tool. 

4. Fit the entire plane in the image. 

5. Then activate “Box select” by clicking on it. This will let you drag the mouse over an area to 

select it. 

6. Select the entire plane. 

7. Right click anywhere on the image and select “Properties.” 

8. In the color dropdown menu, pick a color. In the example, a dark gray was chosen. 

9. Click “Apply.” 

10. Repaint the picture. 

We have a basic plane, but no one could fly it. Let’s add a window to the cockpit. This step will show 

how to use a very powerful variant of the “Move/Copy” tool and how to modify existing surfaces. 

Methods like these are extremely useful in constructing a CEM. 

1. Plot the cockpit surfaces with assigned color: PLOT SI COCKPIT ASGD 

2. Add the cockpit lines: PLUS L COCKPIT 

3. Check which sets are open: PRNT SE 

4. Close any open sets that aren’t PLANE using SETC setname. 

5. Open a new set, WINDOW: SETO WINDOW 

6. Create the lines for the new window: 

a. Navigate to “Create/edit points” in the “Build” tree. 

b. In the default “Coordinates” option, change the dropdown to “Pick position on 

surface…” 

c. A window will pop up. Select the upper face of the cockpit, being mindful that the 

positive y-axis is up. 

d. The mouse should now look like a crosshair. Select a position on the surface to be the 

lower right corner of the window (from the pilot’s perspective). 

e. Click “Apply.” 



f. Add the point to the image: PLUS PA WINDOW 

g. Sweep the new point up 750 mm using either the command line or the GUI, whichever 

you prefer. For convenience, the command is: SWEP pnt ! TRA 0 750 0, where pnt is the 

point made in the previous step. 

h. Add the new line to the image, in blue: PLUS L WINDOW B 

i. Mirror the line using the “Move/Copy” tool in the “Build” tree: 

i. Make sure “Copy” is selected 

ii. Select the new line 

iii. Use the mirror option 

iv. The plane should be defined by the midpoints of the upper and lower edges of 

the cockpit, along with the tip of the cockpit. 

v. No part name is necessary. 

j. Repaint the picture. 

k. Connect the end points of the two new lines to each other to make a rectangle: 

i. Command line: LINE ! pnt1 pnt2, where pnt1 and pnt2 are the points to 

connect. 

ii. GUI: Navigate to “Create/edit lines” in the “Build” tree. Select the two end 

points and click “Apply.” 

l. Repaint the picture. 

7. Move the window lines onto the cockpit surface: 

a. Navigate to “Move/Copy” 

b. Make sure “Move” is selected. 

c. Use the “Project” option. 

d. Type WINDOW into the selection field in the top right and hit enter. 

e. For the reference shape, click the top surface of the cockpit. 

f. Click “Define…” so we can pick the direction of projection. 

g. In the top left of the popup, click absolute. 



h. Type any positive number into the “dX” field. In the example, 100 is used. Leave the 

other fields as zeroes. This tells CADfix to only change the X coordinates of the things 

being moved and only in the positive direction. 

i. Click “OK.” 

j. Click “Apply.” 

k. Repaint the picture. It should look like this: 

 

You’ll notice that many more points have been created. This is a result of how CADfix projects lines onto 

embedding shapes. You might also notice that the upper line isn’t perfectly straight. That is because the 

embedding shape isn’t perfectly flat. This detail likely won’t be noticeable when the model is meshed 

into a finite difference problem space. 

8. Close the WINDOW set: SETC WINDOW 

9. Open the COCKPIT set: SETO COCKPIT 



10. Split the upper cockpit surface using the window lines: 

a. Command line: SSPL surf WINDOW 5 

i. Recall that you can use the arrow keys to highlight “surf” in the menu on the right 

side of the screen, then you can use the mouse to select the surface. 

ii. The “5” at the end of the command is the tolerance. This option tells CADfix how 

accurately to do the split. Units are in model units (mm for this model). 

b. GUI:  

i. Navigate to the “Split” tree of the “Tools” tab and select “Split surfaces with lines.” 

ii. Pick the top surface of the cockpit. 

iii. Type WINDOW into the “Pick lines” field and hit enter. 

iv. Change the tolerance to 5 mm. This ensures that the split will succeed. 

v. Click “Apply.” 

vi. Repaint the picture. 



11. The cockpit now has a window shaped division, but isn’t grouped properly in sets. The window 

needs to be added to the WINDOW set and removed from the COCKPIT set.  

a. Press escape to ensure that nothing is selected 

b. Activate the “Pick surfaces” by clicking it above the image. 

c. Pick the window of the cockpit. 

d. Type: SETA WINDOW SELE 

e. Type: SETR COCKPIT WINDOW 

f. Repaint the picture. The window should disappear. That’s because only the surfaces in 

COCKPIT are being displayed and we just removed the window from that set. 

g. Add the window to the image using assigned colors: PLUS SI WINDOW ASGD 

h. Change the assigned color by selecting the window, right clicking, and entering 

properties. Use the dropdown “colour” menu. 

12. Close all sets: SETC ALL 

13. Plot the entire plane, using assigned colors: PLOT SI PLANE ASGD 

  

Geometry Notes 
The intent of this training module is to familiarize the reader with the CADfix and EMA3D interfaces. By 

this point, the reader should’ve seen most of the commonly used GUI aspects of CADfix, as well as been 

introduced to the powerful CADfix command line. Manipulating the model (rotation, translation, and 

zoom) should be comfortable. The reader should understand the basics of controlling what entities are 

shown, or “plotted.” Set management should be beginning to make sense, too. Other training modules 

will teach techniques and methods required to simplify a complex model and make it suitable for a CEM. 

More detail can be added to this simple model (horizontal stabilizers, window apertures, etc.), but the 

scope of this model limits the techniques that can be exemplified. For practice, extra exercises are 

included at the end of this document. Instructions aren’t included for those. However, all of the 

techniques necessary for the exercises have been presented in the “Constructing Geometry” section. It 

is encouraged to try the exercises to help enforce what has been learned and to bring attention to what 

wasn’t understood. 

  



Steps to EMA3D Simulation 
The process of setting up an EMA3D simulation is outlined in the labelling of the toolboxes. This training 

module will follow the order laid out in the numbering of the toolboxes. 

1) General Topics 
In the top left of the screen, click “Tools->Toolbox->EMA3D_#1_GeneralTopics.” This will open the first 

toolbar for EMA3D, replacing the primitives opened at the beginning of this training. From this toolbar, 

you’ll find “MPIBlocks” and “EFIdnit.” These are easy ways to change the blocking for parallel runs with 

MPI and define an initial E-field value, respectively. 

This airplane model doesn’t need either of those features, so we’ll proceed to number two. 

2) Units 
Click “Tools->Toolbox->EMA3D_#2_SpecifyUnits.” This opens the second toolbar. There’s only one tool, 

labelled “Units.” Click it and confirm millimeters as units. Click “OK.” 

3) Define Lattice 
Click “Tools->Toolbox->EMA3D_#3_DefiineLattice.” There are two tools 

in this toolbox. The first, “ConLatt,” is used to construct 3D lattices. 

We’ll use this one because we have a 3D model. The second tool, 

“TwoDim,” is for 2D problems. Click “ConLatt.” 

The default values (based on all model geometry) are shown to the 

right. We will change the cell size to 500 mm for all directions. We will 

also change the start and end coordinates for all directions. We will 

add 2 meters of space between the plane and the boundary of the 

problem. 

To check the dimensions of the plane, type: PRNT DIMS PLANE 

This will print the dimensions of the set PLANE. Use the global 



minimums and maximums of the “Line ends.” The section for “All cords” includes points and shapes that 

don’t need to be meshed. 

 



Be mindful that your maximum y coordinate will likely be 

different than the one shown above. We will want the start 

and end coordinates of the lattice to be even multiples of 

the step. If we add increase the boundaries by 2000 mm and 

use the next greatest even multiple, the parameters are 

shown to the right. Click “Apply.” 

  



4) Construct Source Geometry 
Click “Tools->Toolbox->EMA3D_#4_ConstructSrcGeom.” An empty toolbox will replace the previous 

one. At this step, the source and detach geometry need to be made. We will make a wingtip-wingtip 

strike situation. A source line will carry the lightning current to the plane and a detach line will carry it 

away. In the process, we will make four new sets: one to hold just the source line, one to hold the 

detach line, one to hold both, and the last to hold the plane, source, and detach line.  

Source Line: 
First, open the new sets for the source line and the new master set: 

1. SETO SOURCE 

2. SETO MASTER 

Next, make a point at the center of the left wingtip, either with GUI or command line: 

3. Command line: PNT ! corner1 corner2 0.5 

a. Where corner1 and corner2 are points at opposite corners of the left wingtip, 0.5 is the 

ratio of distances between the two points. 

4. GUI: navigate to the “Create/edit points” in the “Build” tree. Use the “Point along a path” 

option. Select the two corner points of the wingtip. Leave the ratio at 0.5. Click “Apply.” 

5. Add the new point to the image: PLUS PA SOURCE 

Sweep the new point 2000 mm in the positive Z direction using your preferred method. For 

convenience, the command is provided below: 

6. SWEP pnt ! TRA 0 0 2000 

7. Add the source line to the image: PLUS L SOURCE 

8. Repaint the picture: REP 

9. Close the SOURCE set: SETC SOURCE 

 Detach Line: 
We will mirror the source line to create the detach line. 

1. Open the detach set: SETO DETACH 

2. Navigate to “Move/Copy” in the “Build” tree. 

3. Select the “Mirror” option. 

4. Click the “Copy” radio button. 

5. Type SOURCE into the selection box to select the source line for copying. Hit enter. 

6. From the dropdown menu, select “Pick midpoint of line.” 

7. Pick lines whose midpoints make an X-Y plane (horizontal lines of the front and rear fuselage 

faces work well). 

8. Because we’ve already opened a DETACH set, the part name doesn’t matter. Leave it as the 

default when the dialogue pops up. Click “OK.” 

9. Add the detach line to the image: PLUS L DETACH 

10. Repaint the picture. 

11. Close DETACH: SETC DETACH 



Wrap-up: 
We will add the DETACH and SOURCE sets to a STRIKE set so we can access both quickly. We will also 

add the PLANE set to the MASTER set. Having separate sets for the model geometry and the master set 

is often useful. The master set will become the meshed set later. We will also close all sets. 

1. SETA STRIKE DETACH SOURCE 

2. SETA MASTER PLANE 

3. SETC ALL 

5) Meshing 
Navigate to “Tools->Toolbox->EMA3D_#5_MeshGeometry.” Three tools should now be visible in the 

toolbox on the right side of the screen. Click the first, “Setup.” This prepared the model for being 

meshed. 

To mesh everything, click the second tool: “Mesh.” Alternatively, you can type MESH into the command 

line. 

On larger and more complex models, it is often advantageous to mesh only a portion of the model to 

reduce computation time. To do this, type: MESH entity into the command line. The entity can be a set 

(DETACH, LEFTWING, etc.), or a piece of geometry (V11, U30, etc.). 

Mesh the entire model: MESH 

Plot the meshed twinkles with the assigned color: PLOT TWI ALL ASGD 

For practice, mesh just the left wing: MESH LEFTWING.  

Repaint the picture. Just the left wing should be showing now. 

We need the entire model, so re-mesh the entire model: MESH. Repaint the picture to confirm the 

entire plane is showing. 



6) Time step 
Click “Tools->Toolbox->EMA3D_#6_DefineTimeStep.” Two tools should be in the toolbox. Click the first 

button, “TimeStep,” in the toolbox. A window will pop up. Enter 8.0e-10 for the time step and 3e-4 for 

the final simulation time. 

The time step was chosen to satisfy the courant condition without being within 10% of the courant 

value. The margin will provide a more numerically stable simulation. 

Click “Apply.” 

Next, click “MagTSteps.” This window controls the parameters for gradual permittivity scaling. Enter the 

values as shown below and click “Apply:” 

Permittivity scaling allows EMA3D to increase the time step without violating the courant condition. 

Scaling reduces the computation time significantly and is a very important EMA3D tool. 

7) Background 
Using EMA3D, the background material can be changed. However, we will be using the default values. 

This tool isn’t needed for this model. 



8) Define Properties 
To run a simulation, EMA3D needs parameters for material properties. To define properties, click “Tools-

>Toolbox->EMA3D_#8_DefineProperties.” Only one tool will occupy the toolbox: “PROPERTY.” Click it. A 

window will pop up. 

Three material properties will be needed for the simple airplane: conductive metallic surfaces, non-

conductive glass surfaces, and perfectly electrically conductive lines. 

1. To make a new material, click “New.” A window will popup: 

2. Enter “METAL” as the name. 

3. Select “Isotropic Surface” for the type. 



4. Click “Apply.” Another window will popup. Fill in the values as follows: 

The conductivity is that of a typical airplane aluminum scaled for use with 500 mm cells. 

5. Click “OK.” METAL has been defined as a material. 

6. In the “New Property” window, enter “GLASS” as a name and choose isotropic surface as type. 

7. Click “Apply.” 

8. In the Isotropic Surface window, leave the conductivity at zero because glass is a very poor 

conductor. Change the permittivity to 35e-12, or roughly 4 times the permittivity of free space. 

Permeability can stay the same. 

9. Click “OK.” 

10. In the “New Property” window, enter PECL as the name and choose “PEC Line” as the type. 

11. Click “OK.” 

12. In the pop up, click “OK;” there are no parameters to change. 

The materials we need have been defined. Now we need to assign them to the parts. The WINDOW set 

will clearly receive the GLASS material. The rest of the plane will be assigned METAL properties. The 

detach line will be assigned the PECL property (the SOURCE line will get a special current density 

property later). 

Notice we don’t have a good way of referring to the metallic portions of the plane. The metallic portions 

are the fuselage, cockpit, leftwing, rightwing, and tail. We could either assign the same property to each 

piece (which would be tedious), or we could make a better way to refer to just the metallic portions. In 

other words, make a set that holds just the metallic portions of the plane. 



As mentioned earlier, the metallic portion can be made by adding up the fuselage, wings, and tail. The 

command to do this would be:  

SETA METALLIC FUSELAGE COCKPIT LEFTWING RIGHTWING TAIL 

It’s worth noting that there is a limit to how many additional arguments can be used with SETA and all 

other set commands, so with a larger model this option will require many lines. Alternatively, we know 

that the metallic portions of our model include anything that isn’t the window. We can create a 

duplicate of the PLANE set named METALLIC and remove the window from METALLIC: 

SETA METALLIC PLANE 

SETR METALLIC WINDOW 

Return to the EMA3D Property Editor window. If you closed it, open it again using the “PROPERTY” tool 

in the toolbox. Click “Assign.” The Assign Property window will pop up. Choose “METAL” from the 

dropdown of available properties. Enter “METALLIC” as the CADfix part. Click “Apply.” 

After clicking “Apply,” change the property to “GLASS.” Enter WINDOW as the CADfix part. Click “Apply.” 

After clicking “Apply,” change the property to “PECL.” Enter DETACH as the CADfix part. Click “OK.” 

All material definitions are now applied. Close the property editor. 

9) MHarness Cables 
Some EMA3D purchases include MHarness. MHarness is used for complex pipe and cable routing and 

probing. The simple airplane in this training module has no pipes or cables, so this tool isn’t needed. 

  



10) Define Source 
Click “Tools->Toolbox->EMA3D_#11_DefineSources.” The toolbox will now hold many tools. Each tool is 

used for different kinds of sources. Sources can be plane waves, magnetic current densities, among 

many others. Electric current densities are used for lightning simulations. To define an electric current 

density source, find and click the tool labelled “EleCurDen.” A window will pop up. 

 

The source file is the file that has the source waveform. A source has been provided and is titled 

comp_a.dat. Enter “comp_a.dat” in the source file name field. 

The identification name is a unique name used to reference the source. We will enter “SSOURCE” in the 

“Identification Name” field. 

We wish to define the source using a line, so we will select “Geometry” as the “Specification Type”.  

Our source line is contained in the SOURCE set, so we can select “Set of Lines” in the “Assign To” field 

and enter “SOURCE” in the “Set Name” field. Alternatively, we can also select the “Single Line” option 

and reference the line directly in the “Line Name” field. Following the default naming convention, the 

line’s name should begin with a “U” and can be found using the command: PRNT L SOURCE 

The “Assignment Type” defines the source direction, our line was created starting at the wingtip and 

traveling outboard, so choosing the “End to Beg” option will define our lightning to travel inboard 

towards the aircraft. To verify this, the command PLOC L SOURCE followed by PLOC SENSE ON can be 

used to show the line direction. Our source line should point outwards like this:  

 



If the arrow points inboard, the “Beg to End” option should be used.  Note: the source direction will not 

change the physics for this simulation, it will, however, change the sign of the final answer.  

Finally, the “Multiplier” can be set to 1, which causes the filled-out window to look similar to: 

 

 

Click “OK.” The source has been defined. 

 

11) Boundary Conditions 
Click “Tools->Toolbox->EMA3D_#12_SelectBdyConds.” Click the only tool in this toolbox. A window will 

appear. Check “ALL” on the “Mur1 (HFLD)” row. The Mur 1 (HFLD) option as a boundary condition that 

approximates an infinite extension of background problem space by absorbing magnetic fields at the 

boundary. Absorbing the magnetic fields reduces the reflections at the boundary. This boundary 

condition has been used with lightning simulation models with great results. 



Leave the bottom three entry fields empty; they are for a different boundary condition. Click “Apply.” 

12) Probes 
For a simulation to be useful, it needs to write data. Probes determine what data is written as outputs 

from the simulation. For this simple airplane, we will make a bulk current probe on the left wing to 

measure attachment current, a bulk current probe on the right wing for detachment current, and a 

surface current animation probe. 

Creating any probe will require going into: “Tools->Toolbox->EMA3D_#13_DefineProbes.” The toolbox 

should now have many tools in it.  

Bulk Current Probe Geometry 
The first probe will be a bulk current probe on the left wing. This probe will need to completely cover a 

cross section of the wing. The first step is to create two points that will be opposite corners of a 

rectangle of the probe. 

1. Plot the left wing with the assigned color: PLOT SI LEFTWING ASGD 

2. Open a set to contain all probes: SETO PROBES 

3. Open another set to contain just the left wing probe: SETO LWPROBE 

The points that define this probe should lie exactly on the mesh grid. They should also share the same Z 

coordinate so that the points make a predictable cross section. There are many ways to do this. One way 

is to: 

4. Add the mesh twinkles of the left wing to the image: PLUS TWI LEFTWING 

5. Navigate to “Create/edit points” in the “Build” tree. 

6. Use the “Point on line” option. 



7. Now the cursor should look like a crosshair. Select a location on the lower forward line of the 

wing, about one cell in from the wingtip. It doesn’t need to be exact. 

8. Click “Apply” in the “Create/edit points” window. 

9. Repeat steps 7 and 8 for the upper back line of the wing. 

10. Close the left wing probe set: SETC LWPROBE 

We will snap these points onto the grid later. Before that, we will make the right wing probe. You could 

mirror the left wing probe, but we’ll use a different strategy for the right wing. 

The special source property that attaches to the left wing means that it can’t be probed directly. That’s 

why the probe was placed on the wing one cell away from the tip. The detach line that connects to the 

right wing doesn’t have any restrictions on it. Instead of probing the wing, the detach line can be 

probed. This means we only need one point in the probe to completely bound the line. 

1. Plot the detach line: PLOT L DETACH 

2. Open a set for the right wing probe: SETO RWPROBE 

3. Using the same “Point on line” point creation tool used earlier, create a point anywhere in the 

interior of the detach line (avoid the 500 mm at either end).  

4. Close the right wing probe set: SETC RWPROBE 

5. Close the PROBES set: SETC PROBES 

All of the points needed for the probes are made. To snap them to the mesh grid: 

1. Change the toolbox: “Tools->Toolbox->Miscellaneous.” 

2. Click the “SnapToGrid” tool. 



3. Enter PROBES as the set of points to move. 

4. Click “Apply.” 

Bulk Probe Properties 
To apply the bulk current probe definitions to the points, change the toolbox back to the Define Probes 

toolbox: Tools-Toolbox_EMA3D_#13_DefineProbes. 

1. Click “BulkCurr” in the toolbox. 

2. A window will pop up. Fill it out as shown: 

3. The bounding point is the point in the set RWPROBE. To find its name, either: 

a. Add the labelled point to the image: PLUS PA RWPROBE 

b. Print the point in RWPROBE: PRNT P RWPROBE 

4. Enter the point name in both of the bounding point fields. 

5. Click “APPLY.” 

6. Change the set name field to LWPROBE. 



7. Change the bounding points to the points in the LWPROBE set. Leave the time fields and normal 

direction unchanged. 

8. Click “OK.” The bulk current probes have been defined. 

Animation Probe Set Creation 
The animation probe needs a set of nodes from meshed surfaces. To make a set of just the surface 

nodes: 

1. Create a set, SJSA, with all surfaces 

2. Complete the set down to the nodes. 

3. Remove all surfaces from the set. 

4. Create a second set, REMTEMP, with all lines. 

5. Complete the second set down to the nodes. 

6. Remove the second set from the first (removes undesired line nodes). 

The commands for the process are: 

1. SETA SJSA S ALL 

2. COMP SJSA GN 

3. SETR SJSA S ALL 

4. SETA REMTEMP L ALL 

5. COMP REMTEMP GN 

6. SETR SJSA REMTEMP 

Use PRNT SE SJSA to print a summary of the contents of the set SJSA. There should only be nodes, 

labelled as “N.” 



Animation Probe Definition 
In the Define Probes toolbox, click “Traditional.” A window will pop up. Fill it in as follows, changing the 

output type to “JS” for surface currents. The stop time is the end of the simulation. The step time is 

chosen to have 50 frames in the animation. 

Click “OK.” The animation probe has been defined. 

EMA3D Review Tool 
Change the toolbox to the Review Tool: “Tools->Toolbox->EMA3D_ReviewTool.” Click the “Review” tool. 

A window will pop up. It should look like: 

Click “Create EMA3D Input File.” Another popup window will appear. Nothing needs to be changed; click 

“OK.” 

When the emin file is created, click “OK” again. Close the review tool window. 

Running EMA3D 
Change the toolbox to the Run EMA3D toolbox: “Tools->Toolbox->EMA3D_Run.” Click the only button, 

labelled “Run_EMA3D.” The EMA3D window will appear, although it might take a moment. 

Click the “Run New EMA3D Simulation” radio button. 

Click “Browse” to find the emin file created earlier. 



Click “Run EMA3D.” This simulation should only take a minute. 

Post-Processing 
There are many ways to post process data output by an EMA3D simulation. The EMA3D GUI has built in 

options for plotting probe outputs. However, large models have hundreds of probes and it is not 

practical to rely on GUI’s for such large projects. For this reason, simple Python scripts have been 

included as examples of how process data outside of any GUI’s. Also included is a more capable Python 

script that can process hundreds of current and voltage data files in succession. 

Some EMA3D probes output files that aren’t stored as .dat files. An example of such a probe is the 

animation probe. The simple airplane simulation used in this exercise has an animation probe, so the 

process will be shown. 

EMA3D GUI Processing 
Once the data files have been created, you can double click them in the Probe window to access the 

data. Because all of the data made by this simulation only have one column, only one possible plot in 



the data window. Double click a column to see its plot. Plots can be plotted one on top of another. 

 

 

Simple Python Scripts 
Our simulation only contained current probes and one animation probe. The Python scripts explored in 

this section are only applicable to the current probe outputs. Included with the documentation for this 

training module are three python scripts: 

1. post_process.py 

2. single_j_plot.py 

3. single_j_plot_cmd.py 

single_j_plot.py 
The first, post_process.py, is the strongest of the included scripts. It will be discussed in more detail 

later. The other two are duplicates of each other except the inputs are entered differently. To use 

“single_j_plot.py,” edit the script in your preferred Python IDE. Because the Spyder IDE is included in the 

EMA3D installation, this training will assume you will be using Spyder. 

To open the script in Spyder, navigate to the simulation directory in a file explorer. Right click 

single_j_plot.py and select “Edit with Spyder.” This will open the script in the Spyder environment. 

If the “Edit with Spyder” option isn’t available, try typing “Spyder” in a Windows search bar. If the 

program appears in the display, select it. If the search didn’t find Spyder, try manually looking for it. By 

default, the EMA3D installation will put the installation in the user’s Documents folder. Look in: 

~\Documents\WinPython-64bit-3.4.3.6” where the version number (3.4.3.6) might vary. Also, on 



systems that don’t support 64bit look for a 32bit installation. Inside this folder there should be 

“Spyder.exe.” Double click it. Using the Spyder GUI, open the Python script. 

Once single_j_plot.py is open in Spyder, change the values for the filename and title in lines 16 and 19, 

respectively. The naming convention for current probes is to use the base name of the .emin file and 

append “bpr#” where # is the instance number of the probe. For our simulation, the base name is 

“basic_plane” which makes the current probe names “basic_planebpr1.dat” and “basic_planebpr2.dat.” 

Current probe 1 is for the left wing. Current probe 2 is for the right wing. 

Inside the Spyder window, make sure a console window is open. Click anywhere in the console to 

activate it. Now click the green triangle to run the python script in the console. The script will create png 

images of plots in the scripts active directory with the title you gave it. 

single_j_plot_cmd.exe 
Instead of editing single_j_plot.py, you can run single_j_plot_cmd.py. The “_cmd” version of the script 

will prompt the user for the file name and title from the command window, without any editing of the 

script. 

An easy way to run the script is to find it using a file explorer, right click the script, then select “Run in 

interactive mode.” A window will pop up and will ask for the file and title to use for the plot. Hit enter 

after each entry. 

Just like the earlier script, a png will be made for the data file in the active directory of the script. 

Stronger Python Script 
The “post_process.py” script is a much faster method to process EMA3D probe outputs. It recursively 

looks through a directory for .dat files and processes each one according a set of labels provided as a csv 

file. This script can be run from within a GUI like Spyder or from a command prompt; use whatever you 

prefer. 

When you run the script, it’ll prompt you for the file name and path of the label file. A file named 

“labels.csv” is provided for the simple plane simulation. Only two .dat files were created by the 

simulation, so only two labels are contained in the csv. The csv holds data of the form: probe suffix, plot 

title.  

After you enter the path to the label document, the script will prompt you for the directory holding the 

.dat files. Enter the directory that holds the output of the simulation. As mentioned earlier, the search is 

recursive so make sure that there aren’t any other .dat files anywhere in the directory. For this reason, I 

moved everything for this simulation into its own directory with no subdirectories. I named this 

directory “original.” 

The script will automatically make a plot for each of the data files. It will also create txt files with peaks, 

peak times, and half peak times. When it’s done, it’ll display the number of seconds used for processing. 



This simulation didn’t make much data, but large models often have hundreds of probes. A quick tool 

like this is crucial when analyzing large models. Another important note is that the simple airplane 

simulation only created bulk current probes. The provided script will process current and voltage probes 

without any extra instruction. 

If this script is used for other models, it may be necessary to change the cell size in the script. The cell 

size is needed to calculate voltage differences from electric field probes. The script is provided with a 25 

mm cell size because that is a typical cell size for detailed aircraft models. The cell size definition can be 

found on line 90. 

This script will be explored in more detail in later training modules. 

Results 
Any of the above methods should result in plots that look something like the below plots, except your 

titles may be different. 

  



Creating an Animation 
The simulation created an .emout file. The .emout has the surface currents recorded for every part in 

model for 50 time steps. When simulating large and complex models, the .emout can be many gigabytes 

large. This simple model will have a much more manageable size. 

To create an animation, the data in the .emout file needs to be processed into a CADfix results database. 

To do this, open a Windows command window. An easy way to open a command window in the proper 

directory is to use a file explorer to navigate to the folder that holds both the CADfix .fbm and the 

.emout. Right click and select “Open an enhanced console here.” However you open a command 

window, make sure to make the active directory the same directory that holds the emout, emin, and 

fbm files. 

Once the command window is opened, type: famfromema3d basic_plane.emout. This command will 

turn the EMA3D results into a CADfix results database. If you named your .emin file something other 

than “basic_plane.emin,” type that name instead (replace .emout for .emin). For large models, making 

the results database can take many minutes. The simple airplane just simulated is so simple, it should 

only take a few seconds on most modern machines. 



Now that the EMA3D results are in a format usable by CADfix, open the CADfix model again. The 

following steps will outline how to make an animation 

1. On the left side of the screen, navigate to the “Results” tab. 

2. In the lower left corner of the CADfix screen, find the “Open results database” button and click 

it. 

3. In the dialogue that opens, select the .frm file that was made by famfromema3d and click “OK.” 



4. In the lower left corner of the CADfix screen, find the “Check Results Database” button and click 

it. CADfix will check that the results database matches the geometry in the model. If the model 

has been modified and meshed since the simulation, this results might not match. 

5. If the “Maximum node movement” displayed in the command line is 0.000, click the “Accept 

Results Database” button located right next to the “Check Results Database” button. Accepting 

a database will lock the mesh (it can’t be changed) to keep the geometry and results paired. 

6. In the left hand side of the CADfix screen, there should be entries for each time that the 

animation probe captured. Click one select the JCURRENT branch. 

  



7. In the lower left corner of CADfix, navigate to the “Results” tab. Leave the sub-tab on 

“Contours.” Select the “Tartan Contours” radio button.  

8. Click the “Plot” button to plot the surface current densities for the selected time step in the 

image. 

9. CADfix automatically sets the color scale used. By default, it will change for each time step. To 

change it, click “Range…” 

10. A warning will pop up. Click “OK.” Nothing wrong has happened. 

11. Change the radio buttons to “User defined” for both fields. Enter “0” in the “From” category and 

“4e4” in the “To” category. Click “Apply,” then click “Close.” 

12. Rotate the image until the airplane is in a nice view. This will be the view used in the animation. 



13. In the lower left corner of CADfix, navigate back to the “Data” tab. Click “Animate…” 

14. In the next window, stay in the “Multi-step” tab and select all of the animation steps. The 

contour range is saved from our previous edit (step 11). With all of the time steps selected, click 

“Capture.” 

15. Watch as CADfix captures each frame of the animation. 

16. Once all frames are captured, an “Animation Manager” window will pop up. To use it, close the 

“Animate” window. 

  



17. The “Animation Manager” window has controls that allow you to step through the animation, 

play the animation, change the frame rate, and edit the animation. 

Watching the animation and looking at the current probes, it’s clear that some resonance is 

present in the simple plane (see current going back and forth between wings at later times). 

18. When ready, click “File->Save As…” to save a .gif of the animation. 

This marks the end of the required work for this training module. By now, you should be comfortable 

navigating the CADfix toolboxes and build tools. Basic command line controls (PLOT, PLUS, SETA, SETO, 

SETC, and SWEP) should also feel familiar. You should be able to perform simple geometry creation and 

modification using primitives, build tools, and/or typed commands (whichever you prefer). 

The steps required to perform and analyze simple, one-off simulations have also been exemplified. It is 

useful to remember that the order of the steps are outlined in the labelling of the toolboxes. The 

EMA3D GUI should make sense and you should be able to run another .emin file without prompts. 

As users become more comfortable with both CADfix and EMA3D, some of the processes shown in this 

module can be replaced with quicker, more purpose-built methods. Using GUI’s to input thousands of 

material properties or to quickly generate hundreds of lines isn’t reasonable, so quicker methods will be 

required. As these needs develop, CADfix and EMA3D come into their own with their customizability and 

versatility. User-created macros are a must-have in CADfix and batch control of EMA3D greatly increases 



efficiency. As more complex needs arise, contact EMA for help and advice from their experienced 

scientists. 

Practice Problems 
Extra tasks are included in this module with minimal instructions. Hints will be provided with each task. 

In particular, general procedures and methods will be suggested. The methods needed to perform each 

task have already been exemplified earlier in the module. 

Each task will be motivated to be useful beyond just getting more CADfix and EMA3D practice. Tasks will 

include geometry modifications and new simulation parameters. The motivation for each task will be 

presented. 

Before making any modifications, save the model with a new file name to archive each step. 

If a result database has been loaded and accepted to a model, to be able to make any changes you will 

have to type: 

PROC LOCK OFF 

Without the above command, CADfix won’t allow any changes (it’s trying to prevent mismatches 

between model and results). 

Boundary Conditions 
As an easy first problem, try changing the boundary condition to the electric field mur 1. After that, all 

you need to do is create a new emin file. No other changes are necessary. Compare the old and new 

results. The data using the electric field mur 1 is dominated by some sort of resonance. We will explore 

whether this is a result of numerical error (difference of similar numbers, operations of disparate 

numbers, etc.) Use these boundary conditions for the following exercises. We will explore the resonance 

and try to mitigate it. 

The model and data can be found in the folder named “emur.” 

Swept Wing 
The first simulation had wings perpendicular to the fuselage. Sweeping the wings might make the wings 

a less effective resonating chamber (which could contribute to the resonance we saw earlier). Add a 5 

meter sweep to the wings. 



Hints: Move the wing root forward 5 meters using “Move/Copy” or MOVE. If after moving the wing root 

the shaded surfaces don’t display well, type SSIM S PLANE ANA to fix the surfaces. You will need to 

mesh the model after modifying it. After meshing, check the probe locations. Redefine the source (this 

needs to be done because the node numbers changed since the last time it was defined). 

After meshing, make a new emin file and run it. Check if the resonance is still present. If you want to 

have an animation, you will need to redefine the SJSA set (not its properties). Repeat the steps outlined 

in the EMA3D step 12 section of this module to put surface nodes in SJSA. 

The wild oscillations are gone. This most likely means that the oscillations occurred due to numerical 

error. This can happen when very similar fields appear on adjacent nodes and are calculated. 

Fundamental imperfections in the way numbers are represented in computers limit the available 

precision. The result is that numbers that are similar to within a certain precision can lead to errors. This 

can be exemplified very simply: 

It is likely that sweeping the wings created more strongly varying fields inside the wings, eliminating the 

numerical oscillations. 

Changing the boundary condition reduced the boundaries’ ability to absorb the currents generated in 

the problem space. Any instabilities using the magnetic Mur boundary condition flowed out of the 

problem space through the absorbing boundaries.  

The data and model can be found in the folder “swept.” 

Cylindrical Fuselage and Hemispherical Nose 
Maybe changing the fuselage shape will change the resonating characteristics of the plane, too. Change 

the fuselage to a cylinder instead of a box. After that, make the cockpit a hemisphere. 

Fuselage hints: Be mindful of maintaining proper set organization. Start by making a cylinder using a 

primitive. Use the same length and total width (diameter). Remember to delete the solid body (leave 

the surfaces). After the cylinder is made, delete the old box. Use “Move/Copy” to project the wing root 

and tail onto the cylindrical shape of the fuselage. Project the surfaces using two points that will keep 

the projection purely in the X-Z plane. 

Cockpit hints: To make a hemisphere, first make a sphere at a point (tool in the primitive toolbox). 

Delete the body, then delete the aft half of the sphere. Don’t worry about making a window. In fact, just 

ZAP the window set. Don’t forget to delete the old rectangular cockpit, too. 

You will have to assign properties to any new geometry you created (fuselage and cockpit). You will also 

need to mesh the whole model again. After meshing, redefine the source. If you want an animation, 

redefine the SJSA set (not its properties). 

Process the data in any way you prefer. 

The data and model can be found in the set “cylinder.” 


