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EMA has updated these simulation instructions. Contact us anytime with questions or concerns. 
 

Background 

This demonstration is the simulation portion of a DO-160 Cable Susceptibility Measurement. The actual 
test was done in July 2014, and the files "measCurrent.dat" and "measVoltage.dat" are the results from 
that test. 

 

Import the Model 

1. Open CADfix. 
2. Navigate to the “File” drop down menu; click “Open”. 
3. Navigate to whatever folder you want to work out of. 
4. Type “demo.fbm” in the “File name” section. 
5. Click “Import”. 

Create the Box Geometry 

1. Type “SETO GPLANE” in the command window. Here you are opening and creating a set called 
GPLANE, to create the planar box part of our geometry. 

2. Open the Tools tab on the left side of the screen. 

3. Expand the “Build”  menu. 
4. Select “Create/edit points”. 
5. In the “Position” box on the lower left, enter “0.0” in X, Y, and Z and click “Apply” and note that 

Q1 is created (Important: the name of your point may be different than Q1, this may happen 
because CADfix automatically names points, lines, etc. Generated names will appear in the 
lower left hand corner of the window after the feature is generated. Please keep careful track of 
names and do not solely rely on this document. For example if your point is named Z5 instead of 
Q1 replace all instances of Q1 in this document with Z5). 

6. Select “Create/edit lines”. 

7. Find the “Swept line” tab . 
8. Enter “Q1” as the Sweep Point. 
9. In the “Vector/Axis” section click “Define”. 
10. In the “Define Vector/Axis” dialog, find the “Type” field and click the “Absolute” radio button. 
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11. In the “Translation” field, enter “20.0” in the “dY” field, as shown below. 

 
12. Click “OK” in the Dialog and then click “Apply” in the “Create/edit lines” tool. 
13. Line “U1” should be displayed. 
14. Select “Create/edit surface”. 

15. In the “Create/edit surface” tool, select the “Swept surface” tool . 
16. Type line “U1” in the “Sweep line” field. 
17. In the “Vector/Axis” section click “Define”. 
18. In the “Define Vector/Axis” dialog, find the “Type” field and click the “Absolute” radio button. 

 
19. In the “Translation” field, enter “72.0” in the “dX” field and “0.0” in the “dY” and “dZ” fields, as 

shown below. 

 



19. Click “OK” in the Dialog and then click “Apply” in the “Create/edit surface” tool. 
20. Surface “V1” should be displayed. 

 
21. Type “SETC GPLANE” in the command window. This closes the GPLANE set, which contains the 

surface V1 and all of the lines and points it contains. 
22. Type “CLIP BOTH OFF”. This removes the clipping planes so that can see all of the geometry. 
23. Type “PLUS SI GPLANE”. This displays the surfaces of GPLANE. 

Create the Cable 

1. Type “SETO ENDL” in the command line. This creates a new set, named “ENDL”, which will be 
the left vertical piece that connects the cable to the GPLANE. 

2. Open the Tools tab on the left side of the screen. 

3. Expand the “Build”  menu. 
4. Select “Create/edit points”. 
5. In the “Position” box on the lower left, enter “6.0” in X, “10.0” in Y, and “0.0” in Z and click 

“Apply” and note that point Q5 is created. 
6. Select “Create/edit lines”. 

7. Find the “Swept line” tab . 
8. Enter “Q5” as the Sweep Point. 
9. In the “Vector/Axis” section click “Define”. 
10. In the “Define Vector/Axis” dialog, find the “Type” field and click the “Absolute” radio button. 

 
11. In the “Translation” field, enter “0.0” in the “dX” field, “0.0” in the “dY” field, and “2.0” in the 

“dZ” field, as shown below. 



 
12. Click “OK” in the Dialog and then click “Apply” in the “Create/edit lines” tool. 
13. Line “U5” should be displayed. 
14. Type "SETC ENDL". This closes the set named “ENDL”. 
15. Type "SETO ENDR". This creates and opens the set named “ENDR”, which will be the right 

vertical piece that connects the cable to the GPLANE. 

16. Open the Tools tab on the left side of the screen. 

17. Expand the “Build”  menu. 
18. Select “Create/edit points”. 
19. In the “Position” box on the lower left, enter “66.0” in X, “10.0” in Y, and “0.0” in Z and click 

“Apply” and note that point Q7 is created. 
20. Select “Create/edit lines”. 

21. Find the “Swept line” tab . 
22. Enter “Q7” as the Sweep Point. 
23. In the “Vector/Axis” section click “Define”. 
24. In the “Define Vector/Axis” dialog that pops up, find the “Type” field and click the “Absolute” 

radio button. 

 
25. In the “Translation” field, enter “0.0” in the “dX” field, “0.0” in the “dY” field, and “2.0” in the 

“dZ” field. 
26. Click “OK” in the Dialog and then click “Apply” in the “Create/edit lines” tool. 
27. Type “SETC ENDR” in the command window. This closes the “ENDR” set. 
28. Type “SETO CABLE”. This creates and opens the “CABLE” set, which will be the horizontal piece 

of the cable, that connects ENDL and ENDR. 

29. Select the “Two Points” option  in the “Create/edit lines” tool. 
30. Click on the endpoints of lines U5 and U6 (points Q7 and Q8) in the tool and click “Apply”. 
31. Note line U7 is created as shown below. 



 
32. Type “SETC CABLE” in the command window. 
33. Type "SETA ENDS ENDR ENDL" in the command window. This creates a new set, called “ENDS”, 

and adds sets ENDR and ENDL to that set. 
 

Create the Define the Units and the Lattice 

1. Navigate to Tools->Toolbox->EMA3D_#2_SpecifyUnits in the top menu. 

2. Go to the button on the right labeled “Units” . 
3. Select the “Inches” radio button and click “OK”. 
4. Navigate to Tools->Toolbox->EMA3D_#3_DefineLattice in the top menu. 

5. Go to the button on the right labeled “ConLatt” . 
6. Enter the values as shown below and click “OK”. These are defining the size of the lattice. For 

other problems, you can click “Minimum Boundary” and EMA3D will automatically selected the 
minimum lattice boundaries for you. 

 
7. Type “PLUS LATE” in the command window and inspect the computational lattice. 



 

Mesh the Geometry 

1. Navigate to Tools->Toolbox->EMA3D_#5_MeshGeometry in the top menu. 

2. Select “Mesh”  from the right menu. 
3. Go to View -> Display Settings -> Mesh and set the edge color and shrink factor both to “Off”. 

 
4. Click OK. 
5. Type “PLOT TWI ALL” in the command window and inspect the mesh to make sure everything is 

present, as shown: 



 

Define Time Step 

1. Open Tools->Toolbox->EMA3D_#6_DefineTimeStep. 

2. Select “TimeStep”  from the right menu. 
3. Enter “8.5e-11” in the “Time Step (s)” field. (This is less than 90 % of the Courant criterion for a 

2” uniform mesh). 
4. Enter “5.015E-4” for the final simulation time, as shown below. EMA3D will automatically 

calculate the maximum time step based on the Courant condition. You can enter any time step 
that is less than or equal to the provided number.  

 

 
5. Click “OK”. 

6. Select “MagTSteps”  from the right menu. 
7. Enter the following to gradually increase the permittivity value as the quasi-magnetostatic 

condition is met. 



 
8. Click “Apply”. 

Define the Properties 

1. Open Tools->Toolbox->EMA3D_#8_DefineProperties. 

2. Select “PROPERTY”  from the right menu. 
3. Click “New”. 
4. In the “Name” field of the “New Property” window, type “ALUM”. 
5. In the “Type” spin box, change the definition to “Isotropic Surface”, as shown below. 

 
6. Click “Apply”. 
7. Change the “Electric Conductivity (sigma)” field to “3.8e7”. 

 
8. Click “OK”. 
9. Click “New”. 
10. In the “Name” field of the “New Property” window, type “PECL” as shown below. 
11. In the “Type” spin box, change the definition to “PEC Line”. 



12. Click “OK”. 
13. Leave the other fields as the default, and click “OK”. 
14. Click “Close” on the EMA3D Property Editor. 

Assign the Materials 

1. Open Tools->Toolbox->EMA3D_#8_DefineProperties. 

2. Select “PROPERTY”  from the right menu. 
3. Highlight “ALUM” in the “Property Editor” popup window. 
4. Click “Assign” in the “Property Editor” popup window. 
5. Type “GPLANE” in the “Assign Property” popup window. 
6. Click “OK”. 
7. Highlight “PECL” in the “Property Editor” popup window. 
8. Type “ENDR” in the “Assign Property” popup window. 
9. Click “OK”. 
10. Click “Close” on the EMA3D Property Editor. 

MHARNESS Cables 

1. Select the “Harness Editor” tool in the MHARNESS toolbox. 
2. Right click on “Routes” and select “New – Shield with conductors”  
3. Enter “TSP1” as the “Route Name” 
4. Type “CABLE” into the “Select Route Segments” Box as shown 

below. Then press “Enter.” 

 
 

5. Press “New” for the “Select Route Properties”. 
6. Enter “TSP” as the “Property Name”. Select “Twisted Shielded Pair” as the “Cable Type”, change 

the “AWG” to “22”, and leave all other values as default as shown below. 



 
7. Click “Apply” 
8. Select both ends of the cable for the “Termination Points” as shown below. 

 
9. Click “Apply” 
10. Currently the cables are shorted to the end lines along with the shields. While the shield should 

stay shorted, we will need to open one end of the cable. 
11. Expand the “Routes” tree and the “ROUTE1” tree in the harness editor.  
12. Right-click on the first cable “TSP1C1” and select “Edit.” 
 

 



13. Check the “Use Second Termination Boundary Condition” box and enter the values as shown 
below. 

 
14. Click “Apply” 
15. Repeat this process for “TSP1C2.” 
16. Open the “Sources” tab. 
17. Right click on “Cable Current” and select “New”. 
18. Enter the values as shown below. 



 
19. Click “Apply” 
20. Right Click on “Cable Voltage” and select “New”. 
21. Enter the values as shown below. 

 
22. Click “Apply”. 
23. Click “Write” at the bottom of the window. 
24. A popup window will appear, press “Save” 



Define Sources 

1. Type “PLUS L ENDL” in the command window. This displays the ENDL line name. 

 
2. Observe the line name which in this case is “U5”. 

3. Click “EleCurDen” from the right menu (Electric Current Density Source). 
4. Enter an Identification Name in this case it is “currden.” 
5. Enter “injected_tsp_current.dat” in the “Source File Name” field, which is the experimentally-

generated cable current source. 
6. Select “Geometry” as the “Specification Type.” 
7. Select “Sigle Line” in the “Assign To” field. 
8. Click “Beg to End” as the “Assignment Type” field. 
9. Enter “U5” in the “Line Name” field, where U5 is the name of the line above. Change the 

multiplier to “1.0.” 

 
 

10. Click “OK”. 

Select Boundary Condition 

1. Open Tools->Toolbox->EMA3D_#11_SelectBdyConds. 

2. Select “BOUND”  from the right menu. 
3. Click the “Low Freq (EFLD)” radio button in “ALL” column of the “Boundary Condition Editor” 

popup window. 
4. Click “APPLY”. 

 



Prepare the 3D Simulation Input File 

1. Click the Save button. 
2. Open Tools->Toolbox->EMA3D_ReviewTool. 

3. Select “Review”  from the right menu. 
4. The Model Review Tool should contain the same elements as shown below:

 
 

5. Review the simulation details, and click “Create EMA3D Input File” when ready to proceed. 
6. Note the file name and click “OK” in the popup window. 
7. Click Save in CADfix to preserve the model. 

Run EMA3D Simulation 

1. Select Tools -> Toolbox -> EMA3D_Run from the top menu. 

2. Select “Run_EMA3D”  from the right menu. 
3. Select the “Run New EMA3D Simulation” radio button. 
4. Click “Browse”. 
5. Select the .emin file by the same name created in the step above (demo.emin) and click “Open”. 
6. Click “Run EMA3D”. 
7. Wait for the simulation to complete.  

 
 



8. Double click the "Probe Type" number 2 entry. 
9. Double click the “Probed Property” number 1 entry. Observe the plot on the right hand side. The 

resulting curve is the voltage coupled to the inner pins. It should have a peak voltage of about 
20 mV as shown below. 

 
10. Repeat the previous two steps for the number 3 entry in “Probe Type”. 

 
 

Using a plotting program of your choice or the included 'compare.py' file you can plot the files 
"voltage.dat" and "measVoltage.dat" on the same plot. The result is a comparison of the simulated 



voltage just calculated, and the voltage measured during the actual experiment. If you choose to use the 
included python file 'compare.py' make sure you have Python Version 2 as well as the NumPy, SciPy, and 
Matplotlib libraries. Also make sure the file is in the same folder as voltage.dat and measVoltage.dat 
when it is executed. The python script will automatically generate the image once it is run. The image 
below is what you should expect to see: 

 
 


